UPD в защиту Каталины

Опубликовано Опубликовано в рубрике Обзоры

Раздаются беспокойства и сомнения: в интернетах описывают гораздо большие ужасы, чем мы написали.

Поясняем.

 

О 32-х битных программах

О том, что macOS больше не будет поддерживать 32-х разрядные программы, Apple предупреждала за два года. Они не должны были работать ещё в macOS High Sierra 10.13 (две macOS назад), и то, что работали – милость, а то, что перестали – не сюрприз. Крики о том, что «Apple погасила свет рубильником» – неправда.

 

О неработающих фотошопах, принтерах и пр.

В том, что компании Adobe, Epson и многие другие (не первый год живущие) умудрились сделать сами программы 64-х разрядными, а их установщики – 32-х разрядными, виновата не Каталина и не Apple.

 

О подставе тру-профессионалов

Настоящий профессионал – а накрыло фотографов, видеоредакторов и даже музыкантов (там и с программами для диджеев проблемы, т.к. все они использовали библиотеку iTunes, а его больше нет + имя библиотеки другое) – так вот, нормальный профессионал никогда не бросится обновлять систему при её выходе.  Поэтому крики “Я мега-фотограф, а у меня сюрприз от плохой Apple!”, значат, что про «мега» ему только кажется, а компьютером (любым, не только Mac) он пользуется первый год или просто не умеет (приходите, научим. «Mac для начинающих» – это не только для тех, кто Mac первый раз видит, но и гораздо больше для тех, кто годами бьётся головой в стену и даже этого не понимает).

 

О длинных списках вдруг не работающих программ

Главное в этих списках – не имена невинно убиенных (известные и популярные): Transmit, 1Password, iStats Menu, VMWare Fusion, Creative Cloud, Parallels Desktop и пр., а ИХ ВЕРСИИ. Перестали работать, например: 1Password 2.12 (текущая версия 7.3.2); VMWare Fusion 3.1 (текущая версия 8.Х.Х.) и так далее по всему списку: не работают версии, выпущенные по пять поколений назад. Как можно пользоваться (и вообще, зачем?) версиями, которые уже по пять лет дырявые и не латаются (особенно 1Password), большой вопрос.

***

Поэтому, как и написано в изначальной статье, Каталина просто сыровата, а её глюки – нормально для первой версии. В любом случае, их гораздо меньше и они не такие страшные, как, например, у macOS High Sierra 10.13, которая напакостила с порога, потом продолжала пакостить весь год, и чьи глюки Apple так и не поправила до самого конца – вплоть до последней версии macOS High Sierra 10.13.6.

Единственное справедливое обвинение в подставе – то, что в изначальной статье мы указали первым пунктом: что в Системных настройках теперь предлагается обновить не текущую версию macOS, а перейти на следующую (+ на иконке Системных настроек в Dock теперь постоянно горит цифра: «обновление», «не тупи», обновись», «warning!», «обожемой обожемой!»). Вот только это – вина Apple, потому, что – «введение в заблуждение». Но и его последствий можно избежать, если не торопиться, быть внимательнее или хотя бы звонить доктору до, а не после.

Что же касается автоматических обновлений, то у настоящих профессионалов и всех, кто ездить на Mac учился, а не «Да там всё просто!», эта опция отключена.